Jan 102011
 

I stumbled across an annoying issue with the VI client and backward compatibility. I kept receiving the error “The server closed the connection. The underlying connection was closed: the connection was closed unexpectedly.”

It was also raised in this VMware community article:

http://communities.vmware.com/message/1494058

I was using the 4.1 client to connect to the ESXi 4.0 server and assumed that this would be acceptable as it should be backwardly compatible. Unfortunately this is not the case. While it is not a huge issue for me to have the 2 versions installed I can imagine a larger estate with both ESXi 4.0 and ESXi 4.1 to be a little more irritating.

This is not a show stopper at all but backward compatibility is something every company should get correct.

In addition if you have already had the 4.0 VI client installed this is not an issue as it simply loads previous version without prompting.

Post to Twitter

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)

Twitter links powered by Tweet This v1.8.3, a WordPress plugin for Twitter.