Jun 212012
 

When following the Cisco Cheat sheet for deploying the Nexus 1000v for deploying the Nexus 1000v in L3 mode, make sure one of the first commands you run (or when applying your config) is ‘feature LACP’ without it you cannot activate your LACP port channel.

image

I set up something similar to the above, the port-channel is between the server ports and the 5k (2ks acting as fabric extenders) and setup to load balance using LACP. This is design was only recently supported by Cisco as previously you would have had to load balance traffic on the port channel via MAC-Pinning.

This annoying little oversight caused me an hour of grief on a customer site as the port-channel on the 5k and 1k would not become active until this feature was enabled.

To enable this feature:

n1000v# config t

n1000v(config)# feature lacp

http://www.cisco.com/en/US/docs/switches/datacenter/nexus1000/sw/4_2_1_s_v_1_4/command/reference/n1000v_cmds_f.html#wp1404742

Post to Twitter

Mar 252011
 

Rather non descriptive and annoying error when setting up a 1000v for the first time. You can also see the “HTTP/1.1 400 Bad Request” along with the error message.

Cause:

Incorrect port

Or

You are connecting to a ESX server and no the vCenter server.

Resolution:

Change the port in vCenter to port 80.

‘Administration -> vCenter Server Settings  -> Ports’

image

Or

Point it to the correct vCenter server.

Post to Twitter

Twitter links powered by Tweet This v1.8.3, a WordPress plugin for Twitter.